Désolé, une erreur est survenue dans SharePoint

- Désolé, quelque chose a mal tourné dans SharePoint
- Désolé, quelque chose a mal tourné lors de l'accès au dossier de bibliothèque SharePoint partagé externe
- Désolé, quelque chose a mal tourné sur une page de site avec un composant Web bibliothèque Pages ajouté
- Désolé, quelque chose a mal tourné lors de l'ouverture ou du chargement de pages SharePoint ou lors de la création du site My Site Host
- Désolé, quelque chose s'est mal passé lors de la création d'une Collection de Sites
- Désolé, quelque chose s'est mal passé dans le Flux de Travail SharePoint
- Désolé, quelque chose s'est mal passé dans la Recherche SharePoint
- Désolé, quelque chose s'est mal passé lors de la sauvegarde du site SharePoint en tant que modèle
Cet article explore les causes et solutions de l'erreur "Désolé, quelque chose a mal tourné dans SharePoint", apportant des réponses concrètes pour divers scénarios courants.
Vous pouvez rencontrer l'erreur Désolé, quelque chose a mal tourné dans SharePoint pour plusieurs raisons ou différents scénarios, car il s'agit d'une erreur générique. Dans cet article, nous examinons les diverses instances de cette erreur particulière et les solutions correspondantes à chaque cas.
En fonction de la tâche que vous avez effectuée ou que vous étiez en train d'effectuer lorsque vous avez rencontré l'erreur sur votre système, référez-vous à la ou aux sections ci-dessous pour les solutions les plus appropriées afin de résoudre le problème. Gardez à l'esprit que vous pourriez avoir besoin d’être assisté par un administrateur SharePoint pour appliquer et finaliser avec succès les corrections décrites.
Lorsque vous partagez un dossier de bibliothèque SharePoint avec certains utilisateurs en dehors de votre organisation en utilisant Partager > Envoyer le lien > Personnes spécifiques > Autoriser l'édition, certains utilisateurs peuvent signaler le message d'erreur suivant lorsqu'ils essaient d'accéder :
Désolé, quelque chose a mal tourné
Cette opération n'est disponible que pour un site avec des autorisations uniques.
Que ce problème se produise dans des dossiers d'une collection de sites ou dans des dossiers de toutes les collections de sites, ou que la même erreur soit signalée lors du partage de fichiers individuels avec les utilisateurs concernés, ou si ces utilisateurs touchés utilisent le même locataire d'email, vous pouvez suivre les étapes ci-dessous pour résoudre le problème :
- Naviguez vers Centre d'administration SharePoint > Politiques > Partage et vérifiez si une date d'expiration a été définie pour les utilisateurs invités.
- Naviguez vers Centre d'administration Microsoft 365 > Utilisateurs > Utilisateurs invités et supprimez les utilisateurs concernés, puis partagez à nouveau le dossier.
- Naviguez vers Paramètres du site > Fonctionnalités de collection de sites et désactivez la fonctionnalité de mode de verrouillage des autorisations des utilisateurs à accès limité.
Désolé, quelque chose a mal tourné sur une page de site avec un composant Web bibliothèque Pages ajouté
Vous rencontrez cette erreur lorsque vous sélectionnez Afficher les ressources associées dans la page Contenu et Structure du site (sitemanager.aspx). Cela peut se produire si un composant Web de vue de liste qui consomme une bibliothèque de publication ou de pages a l'option Exiger l'approbation du contenu activée. Pour résoudre ce problème, faites ce qui suit :
- Créez une page dans la bibliothèque de pages et ajoutez le composant Web là, au lieu de créer la page dans la bibliothèque de pages du site.
- Désactivez Exiger l'approbation du contenu pour les éléments soumis sur la bibliothèque de la page.
Lorsque cette erreur se produit, vous obtiendrez le message d'erreur complet suivant :
Désolé, quelque chose a mal tourné
Nous avons des difficultés à charger certaines parties de cette page, mais vos documents ne sont pas affectés. Pendant que nous travaillons à la résoudre, vous pouvez continuer à utiliser vos documents comme vous le feriez normalement.
Cette erreur peut survenir lors de la création du site My Site Host parce que le Service de Profil Utilisateur n'est pas connecté à l'application Web correspondante. Dans ce cas, pour résoudre le problème, vous devez simplement :
- Recréer l'application de service de profil utilisateur et MySite.
- Connecter votre application Web avec le Service de Profil Utilisateur pour que le site s'ouvre correctement.
Vous rencontrerez cette erreur lors de l'ouverture ou du chargement d'une page ou d'un site SharePoint, pour les raisons suivantes :
- Problème de serveur interne – Si vous avez SharePoint hébergé en interne sur vos serveurs, alors pour tout problème lié au serveur, vous recevrez l'un des codes d'état HTTP courants lorsque vous accédez à un site SharePoint. D'autre part, si vous avez SharePoint Online, vérifiez si Microsoft a publié des incidents sur la page des administrateurs de locataires. Les erreurs de serveur interne proviennent des serveurs SharePoint ; un utilisateur final ne peut pas les résoudre tant que le problème de serveur n'est pas résolu. Si vous recevez une erreur de serveur interne sur votre page SharePoint Online, contactez l'administrateur informatique de votre organisation.
- Permissions insuffisantes ou absentes – Si vous avez des permissions insuffisantes ou aucune, vous ne pourrez pas ouvrir une page SharePoint. Pour tout problème lié à l'accès, y compris...
- En raison d'une politique d'entreprise interdisant l'accès depuis des appareils non professionnels, vous pouvez contacter l'administrateur du site SharePoint pour vérifier votre accès.
- La ressource n'est pas disponible – Vous recevrez l'erreur 404 dans SharePoint en essayant d'ouvrir une page ou un site. Cela peut être dû au fait que la page particulière ou l'ensemble de SharePoint a été supprimé, ou que la page, le site ou le dossier SharePoint a été renommé ou déplacé. Dans tous les cas, vous pouvez essayer de restaurer cet élément particulier à partir de la corbeille et vérifier si l'erreur est résolue. Vous pouvez également rechercher le site avec le même nom pour voir si des fichiers ou des pages sont retournés. Si vous ne trouvez pas le fichier/ la page correcte, vérifiez la corbeille de SharePoint et restaurez le fichier à partir de là. Si vous n'arrivez pas à trouver la ressource dans la corbeille non plus, vous pouvez contacter votre service informatique pour voir s'ils peuvent vous aider à le restaurer de leur base de données. Si vous utilisez SharePoint Online, demandez à votre équipe IT de soulever un cas auprès de Microsoft pour la récupération des données après sinistre.
- Problèmes de cache du site – Vous pouvez également avoir des problèmes pour ouvrir une page ou un site SharePoint en raison du cache du site. Dans ce cas, pour un dépannage rapide, vous pouvez appuyer sur Ctrl + F5 pour rafraîchir la page du navigateur qui ne se charge pas correctement. Vous pouvez également essayer d'ouvrir votre site SharePoint en mode incognito ou utiliser un autre navigateur et voir si le site/la page s'ouvre. Si cela fonctionne dans une fenêtre incognito, vous pouvez vider le cache de votre navigateur – Edge | Opera | Chrome & Firefox. Si vous utilisez SharePoint Online, vous pouvez vérifier s'il y a des incidents Microsoft. Pour d'autres problèmes en dehors du cache du site, pour trouver et identifier la cause profonde, essayez de capturer le trafic HTTP de la page d'erreur SharePoint ou bien vérifiez l'Inspecter l'élément de la page du navigateur et capturez le trafic réseau.
Désolé, quelque chose s'est mal passé lors de la création d'une Collection de Sites
Si vous recevez cette erreur lors de la création d'une collection de sites dans SharePoint, vous pouvez la résoudre en recréant l'application web que vous avez créée. Avant de créer une nouvelle application web ou une collection de sites, procédez comme suit :
- Ouvrez Gestionnaire IIS.
- Développez le serveur local dans le coin supérieur gauche.
- Sélectionnez Pools d'applications.
- Sélectionnez Administration centrale.
- Sélectionnez Paramètres avancés.
- Cliquez sur Modifier le pool d'applications dans la colonne de droite.
- Modifiez la limite de temps d'arrêt. Définissez une limite à une valeur supérieure à la valeur par défaut sous le modèle de processus.
- Quittez le Gestionnaire IIS une fois terminé.
En fonction de la manière dont vous avez obtenu le message d'erreur dans le Flux de Travail SharePoint, vous pouvez appliquer les solutions suivantes.
- Créer un nouveau flux de travail. Lorsque vous supprimez et recréez votre Flux de Travail, vous pouvez rencontrer cette erreur. Dans ce cas, pour résoudre le problème, créez simplement un nouveau flux de travail mais utilisez un nom différent
- Vider le DNS. Cette erreur peut se produire à cause de votre DNS. Pour écarter cette possibilité, vous pouvez simplement vider le DNS sur votre ordinateur. Une fois fait, vous pouvez recycler les services de Flux de Travail et de Bus de Services et essayer de publier à nouveau le flux de travail.
- Attribuer des permissions db_owner à votre compte utilisateur. Si l'erreur se produit lors de l'utilisation de l'interface de flux de travail, vous voudrez peut-être changer vos permissions. Pour ce faire, allez dans vos bases de données et attribuez les permissions db_owner à votre compte de service de flux de travail dans votre base de données.
Si vous rencontrez cette erreur en utilisant l'application de recherche dans SharePoint, vous pouvez essayer les corrections suivantes pour la résoudre.
- Créer une nouvelle application de service – Vous devez simplement supprimer l'application de service et ensuite en créer une nouvelle et vous assurer qu'elle est définie par défaut pour votre application.
- Modifier les droits d'accès – Une autre correction applicable nécessite d'ajouter Tout le monde au groupe Membres et de définir les droits d'accès ou les permissions sur Lecture seule. Ce n'est pas la meilleure solution, et ce n'est probablement pas la plus sécurisée, alors utilisez-le à vos risques et périls.
- Activer l'Application de Service de Recherche – Si l'Application de Service de Recherche est désactivée, vous pouvez rencontrer ce problème. Dans ce cas, assurez-vous que l'Application de Service de Recherche est.
- Accédez à Administration centrale > Gérer les applications Web > SharePoint – 80 > Connexions de service et assurez-vous que l'Application de service de recherche est activée.
- Vérifiez si le contrôleur d'hôte de recherche SharePoint est en cours d'exécution – Si le contrôleur d'hôte de recherche SharePoint n'est pas en cours d'exécution, vous pourriez recevoir un message d'erreur lors de l'utilisation de la recherche dans SharePoint. Donc, ouvrez la console des services sur votre ordinateur et assurez-vous que le service de contrôleur d'hôte de recherche SharePoint est démarré et en cours d'exécution.
Si vous obtenez cette erreur lorsque vous essayez de sauvegarder le site SharePoint en tant que modèle, vous pouvez appliquer les correctifs suivants dans un ordre quelconque pour résoudre le problème.
- Modifier les paramètres d'approbation de contenu requis. Pour effectuer cette tâche, procédez comme suit :
- Cliquez sur l'icône d'engrenage ou de roue dentée pour ouvrir les paramètres.
- Choisissez Paramètres du site.
- Allez dans la section Galeries de concepteurs Web.
- Cliquez sur Solution.
- Cliquez sur l'onglet Bibliothèque.
- Cliquez sur Paramètres de la bibliothèque.
- Maintenant, cliquez sur Paramètres de version.
- Trouvez la section d'approbation de contenu.
- Réglez l'option Exiger l'approbation du contenu pour les éléments soumis sur Non.
- Cliquez sur OK pour sauvegarder les changements.
- Sauvegardez le site en tant que modèle. Une fois le modèle créé avec succès, vous pouvez réactiver l'approbation du contenu.
- Publier des modèles d'affichage. Cette erreur peut se produire si vos modèles d'affichage ne sont pas publiés. Si c'est le cas, assurez-vous que les modèles d'affichage sont publiés.
- Supprimer les rendez-vous de calendrier récurrents. Cette erreur peut survenir si vous importez des calendriers d'une version antérieure de SharePoint vers une version plus récente. La version plus récente peut avoir des problèmes avec les rendez-vous récurrents. Dans ce cas, pour résoudre le problème, vous devez supprimer ces rendez-vous récurrents. Si vous ne souhaitez pas supprimer définitivement vos rendez-vous, vous pouvez les restaurer en allant dans Contenu du site > Corbeille et en choisissant l'option Restaurer. Après la restauration des rendez-vous, le problème devrait être résolu définitivement.
- Assurez-vous que le bon fuseau horaire est configuré. Dans certains cas, vous pouvez rencontrer cette erreur si votre fuseau horaire n'est pas correctement configuré. Pour vérifier les paramètres de fuseau horaire dans SharePoint, procédez comme suit, ouvrez Administration centrale > Gestion des applications. Localisez votre application Web et cliquez sur l'icône Paramètres généraux dans le menu de la barre de ruban. Dans la fenêtre des paramètres généraux de l'application Web qui s'ouvre, vérifiez le fuseau horaire par défaut et définissez-le en conséquence. Si la définition du fuseau horaire par défaut est manquante, vous devez vérifier si le bon fuseau horaire est défini sur votre PC. Si vous modifiez le fuseau horaire sur votre PC, retournez aux paramètres généraux de l'application Web et définissez le fuseau horaire de votre serveur, puis effectuez un réinitialisation iis.
- Configurer la collection de sites racine. Si vous créez votre collection dans /Sites/ au lieu de Racine, vous pourriez rencontrer cette erreur. Dans ce cas, vous devez créer une collection de site racine et vérifier si l'erreur est corrigée.
- Assurez-vous que votre compte de domaine a accès au rôle SPDataAccess. Lors de l'utilisation des services d'accès dans SharePoint, vous devez accorder certaines autorisations à votre compte de domaine, comme le rôle SPDataAccess dans la base de données de configuration SharePoint dans SQL Server.
- Redémarrez le service SPTimer. Cette erreur peut également survenir lors de l'ajout d'applications à SharePoint. Dans ce cas, pour résoudre le problème, redémarrez simplement le service SPTimer (OWSTIMER.EXE). Pour éviter une récurrence, redémarrez toujours le service SPTimer chaque fois que vous effectuez un changement de configuration majeur dans SharePoint.
- Vérifiez le service de gestion des applications. Si le service de gestion des applications n'est pas installé, vous pourriez rencontrer ce problème. Pour écarter cette possibilité, procédez comme suit :
- Ouvrez Administration centrale en tant qu'administrateur.
- Allez à Gestion des applications > Gérer les services.
Application.
- Choisissez Nouveau > Service de Gestion d'Application.
- Entrez les informations nécessaires dans les champs du Nom de l'Application de Service, Serveur de Base de Données et Nom de Base de Données.
- Sélectionnez l'option Créer un nouveau pool d'application.
- Entrez le nom du pool d'application.
- Cliquez sur OK pour créer un nouveau service de gestion d'application.
- Après la création du service de gestion d'application, allez dans Paramètres Système > Gérer les Services sur le Serveur.
- Localisez le Service de Gestion d'Application.
- Sous la colonne Action, cliquez sur Démarrer.
- Retournez à Gérer les applications de service et vérifiez si le Proxy d'Application de Service est démarré.
- Ensuite, allez dans Paramètres de Site.
- Cliquez sur Gérer les fonctionnalités de site dans la section Gérer les fonctionnalités de site.
- Localisez l'option Les flux de travail peuvent utiliser les autorisations de l'application.
- Cliquez sur le bouton Activer.
- Ensuite, allez dans Paramètres de Site > Autorisations de l'application de site.
- Copiez la section client de l'Identifiant de l'Application entre les caractères | (barre verticale) et @ (arobase).
- Ensuite, allez à http://{hostname}/{catalog site}/_layouts/15/appinv.aspx.
- Collez la section client de l'Identifiant de l'Application dans le champ ID de l'Application.
- Cliquez sur Recherche.
J'espère que ce post vous aide !
Si le téléchargement SharePoint échoue, vous pouvez résoudre le problème en vidant les documents en cache dans le Centre de Téléchargement Microsoft, puis en le configurant pour supprimer toujours les fichiers du cache lorsqu'ils sont fermés.
Si vous avez des problèmes de synchronisation des fichiers Office, le système de cache de Téléchargement Office peut interférer avec la synchronisation SharePoint. Pour résoudre le problème, sélectionnez l'icône de cloud OneDrive bleue dans la zone de notification, à l'extrême droite de la barre des tâches, puis désactivez le paramètre associé dans les paramètres OneDrive.
Maintenant que tu as fini de lire Désolé, une erreur est survenue dans SharePoint, nous t'invitons à explorer davantage la catégorie Tutoriels. Tu y trouveras d'autres articles intéressants qui élargiront tes connaissances et te tiendront informé. Ne cesse pas de lire et de découvrir plus!
